It is currently Thu Dec 13, 2018 1:06 pm

All times are UTC





Post new topic Reply to topic  [ 18 posts ]  Go to page Previous  1, 2
Author Message
 Post subject: Re: Ignitech Sparker TCIP4 ignition?
PostPosted: Mon Jun 23, 2014 9:41 am 
Offline

Joined: Sat Sep 18, 2010 8:00 pm
Posts: 136
Location: UK
model: 900 SS
year: 1990
delagem wrote:

Glocast, I never understood your comment on why we go in for so much repetition? We keep reading and asking until we understand. If you don't like it, why read it? I do also understand why you don't hang out here much. I don't either. Some of the personalities here are a bit too caustic, hiding behind the guise of being "humorous". Shame, it is a helpful forum.


Glad you updated delagem and to reply and explain my comment, firstly the 'why read it?' above is irrelevant as of course I would read any reply to a thread I had invested some time in??? I could say it was me being partly a little insensitive back then but basically when posting on a thread it's nice to have someone acknowledge the content and possible points you made in it rather than totally ignoring it and spouting out what is essentially the same thing. It was that simple..


Top
 Profile  
Reply with quote  
 Post subject: Re: Ignitech Sparker TCIP4 ignition?
PostPosted: Wed Jul 09, 2014 12:02 pm 
Offline

Joined: Sun Feb 24, 2013 11:14 pm
Posts: 70
Location: Melbourne Australia
model: other
year: 1995
I know of three 900 belt drives with the ignitech unit. I tuned/mapped each one (one is my own M900). They have all worked reliably. They are a fantastic and versatile unit. However, I also have heard of failures due to non resistor plugs. Sometimes voltage spikes caused by another electrical component's failure can take out ignition components. I wouldn't blame the Ignitech for that. I would be interested to know of the Ignitech units that failed in and of themselves, and not as the result of being taken out by a wiring short or bad regulator.

_________________
1995 M900
2004 GSXR750


Top
 Profile  
Reply with quote  
 Post subject: Re: Ignitech Sparker TCIP4 ignition?
PostPosted: Wed Jul 09, 2014 11:29 pm 
Offline
paso grand pooh-bah
User avatar

Joined: Tue Jul 29, 2008 9:50 pm
Posts: 3189
Location: Hilltown,Pennsylvania
model: 906 Paso
year: 1990
improperly shielded crap is still improperly shielded crap regardless of how well it worked before it stopped working

_________________
Ducati,making mechanics out of riders since 1946
There's no problem so bad that a little fixing can't make it worse! : )
If it ain't broke keep fixin it till it is
88 750
90 906
92 907ie


Top
 Profile  
Reply with quote  
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 18 posts ]  Go to page Previous  1, 2

All times are UTC


Who is online

Users browsing this forum: No registered users and 15 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  


cron