ducatipaso.org
http://forums.ducatipaso.org/

First post and an ignition problem!
http://forums.ducatipaso.org/viewtopic.php?f=2&t=7175
Page 1 of 1

Author:  startline [ Wed Jun 17, 2015 1:03 pm ]
Post subject:  First post and an ignition problem!

Firstly hello good to be here and was recommended to try here for an answer, my 1990 900ss has the same ignition as a Paso, here's the problem, all packed to go to the TT and suddenly massive problem, the rear cylinder has stopped sparking at 3700rpm, changed coil leads and same problem still on the REAR cylinder, all leads cables ect are good but as soon as 3700 the rear cylinder plug just stops spark, pickup is working as its a single one so I assume my DIGIPLEX2 is at fault, have I missed anythiing obvious, and if I fit a Paso 750 digiplex will it work ok, sorry to just bounce on with questions but I am desperate to get her running again

Author:  Mc tool [ Wed Jun 17, 2015 8:31 pm ]
Post subject:  Re: First post and an ignition problem!

Not a blocked main jet on that cylinder ?

Author:  startline [ Thu Jun 18, 2015 8:10 am ]
Post subject:  Re: First post and an ignition problem!

No mate the rear plug actually just stops sparking, as I say swapped coils and plug etc and fault remains the same

Author:  startline [ Wed Jun 24, 2015 8:07 pm ]
Post subject:  Re: First post and an ignition problem!

Fitted another ecu, sorted :-)

Author:  higgy [ Wed Jun 24, 2015 9:30 pm ]
Post subject:  Re: First post and an ignition problem!

unlikely the ecm was the issue :banghead:

Author:  MarkST [ Thu Jun 25, 2015 7:32 am ]
Post subject:  Re: First post and an ignition problem!

higgy wrote:
unlikely the ecm was the issue
what's an ecm ?

Author:  paso750 [ Thu Jun 25, 2015 7:43 am ]
Post subject:  Re: First post and an ignition problem!

electronic control module?

Author:  Spaggy [ Mon Oct 29, 2018 12:45 pm ]
Post subject:  Re: First post and an ignition problem!

Is anyone aware of a replacement for the Marelli unit on the 906?
A question asked on here earlier was whether the 750 unit was the same. Does anyone know?
One of my 906's seems to have fried the ecu after connecting up the battery the wrong way round (long story!) and I am looking for a solution as the original units are like hens teeth.

Author:  Spaggy [ Mon Oct 29, 2018 1:38 pm ]
Post subject:  Re: First post and an ignition problem!

In answer to my earlier query, I have found more references to this issue on the forum, so am looking at the Dutch option of an exchange unit via carmo.
If anyone has experience of the results I'd be interested to hear.

Author:  englishstiv [ Mon Oct 29, 2018 9:46 pm ]
Post subject:  Re: First post and an ignition problem!

Are you aware that the first Fiat Uno coils are similar to those used on a 906 and 750?

This is stated in the 906 FAQ I have not used it myself

Here is one on ebay..........

https://www.ebay.co.uk/itm/VE520039-Dry ... SwBt5ZNeZ7

Which means you might find a similar electrical unit used elsewhere in the early Italian vehicles of various types ???

I think you might find there is an early Fiat car that may use a similar Electronic igniter ( there isn't actually an ECU on the 906)

Here is an example of what I mean but you'll need to find one suitable for your 906.

https://www.ebay.co.uk/itm/CENTRALINA-D ... :rk:3:pf:0



Also you might want to contact this company

https://www.silent-hektik.de/Duc_Digi.htm

Author:  Derek [ Tue Oct 30, 2018 9:43 am ]
Post subject:  Re: First post and an ignition problem!

I'm surprised that none of you guys with a 750 or a 906 have fitted an Ignitech ignition system yet. They are being extensively used among 750/900SS owners to replace the Kokusan units. It's certainly something I would consider.
http://www.ignitech.cz/en/

Author:  Spaggy [ Tue Oct 30, 2018 1:22 pm ]
Post subject:  Re: First post and an ignition problem!

Derek.

Thanks for that, but the Kokusan replacement stuff is not compatible with the DigiPlex box, so can't really be used on the 906.
That came from the manufacturer in the last few days.

Author:  paso750 [ Tue Oct 30, 2018 1:50 pm ]
Post subject:  Re: First post and an ignition problem!

Quote:
Thanks for that, but the Kokusan replacement stuff is not compatible with the DigiPlex box, so can't really be used on the 906.

true but a complete conversion to a Kokusan ignition is possible which would require the CDI units, coils, flywheel, pickups and part of the wiring of a P750, 750S, Monster or Sport. Probably not worthwile unless you can grab all the parts for little money.

Author:  Derek [ Tue Oct 30, 2018 6:48 pm ]
Post subject:  Re: First post and an ignition problem!

Spaggy wrote:
Derek.

Thanks for that, but the Kokusan replacement stuff is not compatible with the DigiPlex box, so can't really be used on the 906.
That came from the manufacturer in the last few days.

I'm not suggesting that you convert to Kokusan or a Kokusan equivalent. If you look into the Ignitech website you will see that their modules can be used with practically any motorcycle that has an ignition pickup or crank sensor. I'd be very surprised if one of their modules is not compatible with the 906, replacing the Digiplex with a better product.
Check out the Sparker TCI http://www.ignitech.cz/en/vyrobky/tci/tci.htm
And also Brad Black's blog http://bradthebikeboy.blogspot.com/2018/03/ignitech-tcip4-as-replacement-for.html
And this pdf from ignitech about replacing the Digiplex on the early 900SS http://www.ignitech.cz/old/english/tci/Ducati%20900SS%20Digiplex.doc

Page 1 of 1 All times are UTC
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
http://www.phpbb.com/