It is currently Tue Dec 11, 2018 11:30 am

All times are UTC





Post new topic Reply to topic  [ 6 posts ] 
Author Message
 Post subject: 1991 907ie No Spark! ... ECU, MAE tests?
PostPosted: Mon Dec 03, 2018 8:44 pm 
Offline

Joined: Fri Nov 30, 2018 8:56 pm
Posts: 2
Location: USA
model: 907 I.E.
year: 1991
The 1991 907ie on my bench right now has no spark, and has arrived as a 'none of the shops around town could fix it' kind of thing. My hope is that the ECU and MAEs (#39 power module on schematic) are good, and I will hopefully get some oscilloscope traces this weekend, but am having trouble figuring out some of the signal behavior.

Doing some digging on forum I've found a lot of good info (many thanks to the community)
https://app.box.com/s/3elasen7q7
http://sonic.net/~mikebr/efi/ecu_hdwr.html

The 'known goods' found thus far, having spent some time with a multimeter, are:
1. The fuel pump runs for a few seconds when the key is turned on, then shuts off as expected.
2. Both fused relays toggle (and fuses do not blow) when the key/kill switch engage.
3. The engine cranks with the start switch (switch, solenoid and motor seem OK)
4. The MAE is receiving 12 VDC, and the GND is connected.
5. The coil is receiving 12 VDC, and the GND is connected.

When cranking with the start switch, neither spark plug produces a visible spark.

A spark can be observed on both cylinders at the moment the key is turned off (weird) which leads me to believe the coils are OK, I will OHM them when I get a chance based on the data found on this forum(many thanks).

Looking at the schematic I couldn't tell if the BlueRed(Pin 24) wire common to both MAE plugs was supposed to be a digital common, or some kind of enable/disable voltage? (like the kill switch SCR gate on a CDI)

Pin 24 on the ECU is resting at 0volts with the MAE plugged in with the key on. It bumps to ~0.1 volts (still zero) when the starter is running. Pin 24 floats to 2.5VDC with both connectors removed.

I guess my question is:
Should the Pin 24/BlueRed pull up to 5VDC when the ECU wants the MAE to be able to spark? Or is that zero normal?

My plan is to oscilloscope the Blue wire and the Red wire on each MAE to see if they're getting any signal to spark from the ECU. Will post if I get any interesting pictures.

A few more questions:
Has anyone else had both sides of the Power Module fail?
Additionally, would a dead sensor (such as 33,34 on schematic) or some other ECU feedback signal cause it to intentionally kill spark?
Could a burned out EEPROM do something like this?



Sorry for the long post, just hoping to get her back on the road... thanks in advance for any feedback.
-Ian

_________________
1991 907ie
1979 XS1100
2012 Street Triple R

-I'll fix anything, except your: pinball machine, hot tub, juke box....


Top
 Profile  
Reply with quote  
 Post subject: Re: 1991 907ie No Spark! ... ECU, MAE tests?
PostPosted: Tue Dec 04, 2018 10:08 am 
Offline
paso grand pooh-bah
User avatar

Joined: Thu Nov 03, 2011 10:13 am
Posts: 623
Location: Scotland
model: 907 I.E.
year: 1994
It is unlikely for both MAEs to fail simultaneously so the problem more likely lies with the ECU. Have you made sure that the crank and cam sensors are plugged in the right way round. If they get swapped you will get no spark. If either of them have failed you will not get a spark either. If the fuel pump runs while the engine is turning the timing sensors are likely to be ok.

_________________
1994 907ie
2017 Supersport 939
2015 Scrambler Classic
1982 Pantah 500SL


Scotland


Top
 Profile  
Reply with quote  
 Post subject: Re: 1991 907ie No Spark! ... ECU, MAE tests?
PostPosted: Tue Dec 04, 2018 5:36 pm 
Offline

Joined: Thu Nov 29, 2007 2:38 am
Posts: 293
Location: UK
model: 907 I.E.
year: 1990
Have you checked the Pickup? I would start from there; make sure it works and just in case check the distance from the flywheel "hump" is 0.6- 0.8mm

I wonder if they touched the flywheel or the pickup...

The P7 was fitted to many cars so a Marelli Specialist could check it on the bench to see if it is working.

It could well be also that the eprom got corrupted , one option is to find a working 907 near you go there with your ECU and test it on the other bike, this way you can see if it is the ECU without risking of damaging a "borrowed one " by fitting it to a potentially faulty wiring.

The other thing is the wiring, check all connectors, clean then and lube them with grease, just in case some oxidation is cutting the connections and of course the grounds.


Top
 Profile  
Reply with quote  
 Post subject: Re: 1991 907ie No Spark! ... ECU, MAE tests?
PostPosted: Fri Dec 07, 2018 8:33 pm 
Offline
paso grand pooh-bah
User avatar

Joined: Wed Apr 09, 2008 9:57 pm
Posts: 1066
Location: Manchester, England.
model: 907 I.E.
year: 1992
really silly thing but so simple a fix if its this?

Check the small wire that clips into the solenoid.

Derek has already shown a fix for this and I have already done likewise, if this drops off or is damaged you wont get a spark.

http://ducatipaso.org/forum/viewtopic.php?f=3&t=7892

Check the fuses also as this can also have a detrimental effect also.

Has you bike had any re wiring done as you can also do a mod to boost the spark - has this mod failed?

Check all your wiring also as with my bike a lot of the connectors have failed through age with wires loose and in some areas actually pulled out of the pins.

_________________
DUCATI 907ie
BMW K100RS PATINA CAFE RACER


Top
 Profile  
Reply with quote  
 Post subject: Re: 1991 907ie No Spark! ... ECU, MAE tests?
PostPosted: Mon Dec 10, 2018 5:02 pm 
Offline

Joined: Fri Nov 30, 2018 8:56 pm
Posts: 2
Location: USA
model: 907 I.E.
year: 1991
Thanks for all the responses.

I was able to get some time in with the 907ie over the weekend.

Right off, the fuel pump relay was turning on when the starter was turning. Which I suppose indicates the timing sensors are OK. The sensor pins at the computer showed some voltage wiggle on both sensors (though not sure if it's the correct wiggle) ... sadly the pictures didn't turn out, but at least they're connected well enough and doing something.

The pins to the MAEs are stuck at zero volts when cranking, so the ECU, for some reason, is not putting out the signal to fire. With the computer removed, and the two relays toggled by hand, I injected a 16Hz 5v square wave into the MAEs, (pin 24 digital GND, 25 and 26 as 5v signal to fire)and got healthy spark out of each spark plug. (this eliminates both MAE and wiring to harness as a problem)

The ECU is at least not totally fried. There are no burn marks or indications of excessive heat. The pin 10 signal to toggle the relays is working. The bike does have ~50k on it, so maybe the EPROM is burned out?

So I guess it's time to shop for an ECU? Maybe start with just the EPROM?

Thanks all,
-Ian

_________________
1991 907ie
1979 XS1100
2012 Street Triple R

-I'll fix anything, except your: pinball machine, hot tub, juke box....


Top
 Profile  
Reply with quote  
 Post subject: Re: 1991 907ie No Spark! ... ECU, MAE tests?
PostPosted: Tue Dec 11, 2018 10:15 am 
Offline
paso grand pooh-bah
User avatar

Joined: Thu Nov 03, 2011 10:13 am
Posts: 623
Location: Scotland
model: 907 I.E.
year: 1994
Foc_ian wrote:
Right off, the fuel pump relay was turning on when the starter was turning. Which I suppose indicates the timing sensors are OK.

No. It shows that the fuel pump relay is ok and that the ECU is switching it on and off at switch on, which it should do.
The ECU depends on a signal from the timing sensors to turn on the relay while the engine is turning, either under starter power or under its own steam.
As long the ECU gets the signals from the timing sensors it keep relay switched on and uses the signals from them to create the spark and injection pulses and drive the revcounter.
On the P7 ECU both sensors must be operative. If the crank (M) sensor and the cam (C) sensor are swapped round i.e. M plugged into C loom connector and C plugged into M loom connector there will be no spark either.
The pickups are inductive and should have a resistance of around 680Ω ±10%. They should create a pulse if you wave close to the pickup head.

_________________
1994 907ie
2017 Supersport 939
2015 Scrambler Classic
1982 Pantah 500SL


Scotland


Top
 Profile  
Reply with quote  
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 6 posts ] 

All times are UTC


Who is online

Users browsing this forum: Google [Bot] and 14 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  


cron