It is currently Sun Nov 17, 2019 8:06 am

All times are UTC





Post new topic Reply to topic  [ 5 posts ] 
Author Message
 Post subject: Problem displaying not viewed messages in forum
PostPosted: Sun Sep 18, 2005 8:12 pm 
Offline

Joined: Mon Jul 19, 2004 12:00 am
Posts: 162
Location: Saronno (Varese), Italy
model: 750 Paso
year: 1988
I have problem displaying not viewed messages in the topic list of the forums: sometimes all the not-yet-read messages have the correct white icon, but sometimes they all become red and I can't distinguish already read messages from newest ones... does anyone has the same problem?

LC


Top
 Profile  
Reply with quote  
 Post subject:
PostPosted: Mon Sep 19, 2005 2:20 am 
Offline
paso grand pooh-bah
User avatar

Joined: Tue Oct 26, 2004 12:00 am
Posts: 1304
Location: Kapiti, New Zealand
model: 750 Paso
year: 1988
:cool:


I don't think I've had that problem, Luca, but I'll watch for it.


Top
 Profile  
Reply with quote  
 Post subject:
PostPosted: Mon Sep 19, 2005 2:30 am 
Offline
User avatar

Joined: Sun Feb 27, 2005 12:00 am
Posts: 244
Location: Dexter, MI USA
model: 907 I.E.
year: 1991
Do you use the "back" button on your browser to return to the index, or do you just click on the link on the page?

If you click on the index link at the top of the page, your browser probably reloads it. If it reloads, it will only tag messages as new if they were posted while you were reading the first message.

There may also be a setting in the preferences of the browser that asks how often it should check for updates or something like that. Could be loading a new version of the page even if you use the back button? I don't know... just an idea...

I've not had that problem here by the way.

_________________
-Craig
Team YIKES! Motorsports


Top
 Profile  
Reply with quote  
 Post subject:
PostPosted: Mon Sep 19, 2005 8:31 am 
Offline

Joined: Mon Jul 19, 2004 12:00 am
Posts: 162
Location: Saronno (Varese), Italy
model: 750 Paso
year: 1988
I uses both back button and index link, but I can't replicate the problem systematically... but I guess that if you all have not the same problem, then it's probably caused by my browser.
Thanks,

LC


Top
 Profile  
Reply with quote  
 Post subject:
PostPosted: Mon Sep 19, 2005 11:36 am 
Offline
User avatar

Joined: Fri Jul 16, 2004 12:00 am
Posts: 187
Location: Hartbeespoort Dam, South Africa
model: 750 Paso
year: 1987
Luca,

Do you ever receive "Topic Reply Notification" messages and click on these to look at a specific message, then exit ? If you do it seems to reset when you last looked at the forum.

I don't think the website flags the individual messages as read / unread for each member. What I think it does is keep a "date / time of last access" and it uses this to display the topic status. Therefore, if you use the Topic Reply Notification to view a topic that you have been watching, then leave the site, it updates this date / time flag. Next time you go to the site it only shows as unread those items that have been created / modified since you clicked on the Topic Reply Notification hyperlink.

This would also explain why some people had a problem when the system date got messed up.

Paul


Top
 Profile  
Reply with quote  
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 5 posts ] 

All times are UTC


Who is online

Users browsing this forum: No registered users and 2 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to: