First post and an ignition problem!

discussions specific to the 906 Paso
Post Reply
startline
Posts: 6
Joined: Wed Jun 17, 2015 5:55 am
model: 900 SS
year: 1990
Location: UK

First post and an ignition problem!

Post by startline »

Firstly hello good to be here and was recommended to try here for an answer, my 1990 900ss has the same ignition as a Paso, here's the problem, all packed to go to the TT and suddenly massive problem, the rear cylinder has stopped sparking at 3700rpm, changed coil leads and same problem still on the REAR cylinder, all leads cables ect are good but as soon as 3700 the rear cylinder plug just stops spark, pickup is working as its a single one so I assume my DIGIPLEX2 is at fault, have I missed anythiing obvious, and if I fit a Paso 750 digiplex will it work ok, sorry to just bounce on with questions but I am desperate to get her running again
User avatar
Mc tool
paso grand pooh-bah
Posts: 1794
Joined: Wed Dec 05, 2007 12:35 am
model: 906 Paso
year: 1990
Location: Newzealand

Re: First post and an ignition problem!

Post by Mc tool »

Not a blocked main jet on that cylinder ?
I wish I was young again............Id be heaps smarter than last time
startline
Posts: 6
Joined: Wed Jun 17, 2015 5:55 am
model: 900 SS
year: 1990
Location: UK

Re: First post and an ignition problem!

Post by startline »

No mate the rear plug actually just stops sparking, as I say swapped coils and plug etc and fault remains the same
startline
Posts: 6
Joined: Wed Jun 17, 2015 5:55 am
model: 900 SS
year: 1990
Location: UK

Re: First post and an ignition problem!

Post by startline »

Fitted another ecu, sorted :-)
User avatar
higgy
paso grand pooh-bah
Posts: 3263
Joined: Tue Jul 29, 2008 9:50 pm
model: 906 Paso
year: 1990
Location: Hilltown,Pennsylvania
Contact:

Re: First post and an ignition problem!

Post by higgy »

unlikely the ecm was the issue :banghead:
Ducati,making mechanics out of riders since 1946
There's no problem so bad that a little fixing can't make it worse! : )
If it ain't broke keep fixin it till it is
88 750
90 906
92 907ie
User avatar
MarkST
Posts: 92
Joined: Mon Dec 15, 2014 11:05 am
model: 750 Paso
year: 1987
Location: Sleepy leafy South Birmingham UK

Re: First post and an ignition problem!

Post by MarkST »

higgy wrote:unlikely the ecm was the issue
what's an ecm ?
2004 ST4S
2001 ST4
1987 Paso 750
User avatar
paso750
paso grand pooh-bah
Posts: 5505
Joined: Sun Jul 18, 2004 12:00 am
model: 750 Paso
year: 1987
Location: southern Germany

Re: First post and an ignition problem!

Post by paso750 »

electronic control module?
User avatar
Spaggy
Posts: 13
Joined: Sat Sep 03, 2016 1:17 am
model: 906 Paso
year: 1988
Location: UK

Re: First post and an ignition problem!

Post by Spaggy »

Is anyone aware of a replacement for the Marelli unit on the 906?
A question asked on here earlier was whether the 750 unit was the same. Does anyone know?
One of my 906's seems to have fried the ecu after connecting up the battery the wrong way round (long story!) and I am looking for a solution as the original units are like hens teeth.
Spaggy - Half man, Half machine, Half-arsed Half-wit!
User avatar
Spaggy
Posts: 13
Joined: Sat Sep 03, 2016 1:17 am
model: 906 Paso
year: 1988
Location: UK

Re: First post and an ignition problem!

Post by Spaggy »

In answer to my earlier query, I have found more references to this issue on the forum, so am looking at the Dutch option of an exchange unit via carmo.
If anyone has experience of the results I'd be interested to hear.
Spaggy - Half man, Half machine, Half-arsed Half-wit!
User avatar
englishstiv
paso grand pooh-bah
Posts: 1102
Joined: Wed Apr 09, 2008 9:57 pm
model: 907 I.E.
year: 1992
Location: Manchester, England.

Re: First post and an ignition problem!

Post by englishstiv »

Are you aware that the first Fiat Uno coils are similar to those used on a 906 and 750?

This is stated in the 906 FAQ I have not used it myself

Here is one on ebay..........

https://www.ebay.co.uk/itm/VE520039-Dry ... SwBt5ZNeZ7

Which means you might find a similar electrical unit used elsewhere in the early Italian vehicles of various types ???

I think you might find there is an early Fiat car that may use a similar Electronic igniter ( there isn't actually an ECU on the 906)

Here is an example of what I mean but you'll need to find one suitable for your 906.

https://www.ebay.co.uk/itm/CENTRALINA-D ... :rk:3:pf:0



Also you might want to contact this company

https://www.silent-hektik.de/Duc_Digi.htm
DUCATI 907ie
STIMSON SCORCHER 3 WHEELER
CZ 175 Sport.
User avatar
Derek
paso grand pooh-bah
Posts: 769
Joined: Thu Nov 03, 2011 10:13 am
model: 907 I.E.
year: 1994
Location: Scotland

Re: First post and an ignition problem!

Post by Derek »

I'm surprised that none of you guys with a 750 or a 906 have fitted an Ignitech ignition system yet. They are being extensively used among 750/900SS owners to replace the Kokusan units. It's certainly something I would consider.
http://www.ignitech.cz/en/
1994 907ie
2017 Supersport 939
2015 Scrambler Classic
1982 Pantah 500SL (now sold)


Scotland
User avatar
Spaggy
Posts: 13
Joined: Sat Sep 03, 2016 1:17 am
model: 906 Paso
year: 1988
Location: UK

Re: First post and an ignition problem!

Post by Spaggy »

Derek.

Thanks for that, but the Kokusan replacement stuff is not compatible with the DigiPlex box, so can't really be used on the 906.
That came from the manufacturer in the last few days.
Spaggy - Half man, Half machine, Half-arsed Half-wit!
User avatar
paso750
paso grand pooh-bah
Posts: 5505
Joined: Sun Jul 18, 2004 12:00 am
model: 750 Paso
year: 1987
Location: southern Germany

Re: First post and an ignition problem!

Post by paso750 »

Thanks for that, but the Kokusan replacement stuff is not compatible with the DigiPlex box, so can't really be used on the 906.
true but a complete conversion to a Kokusan ignition is possible which would require the CDI units, coils, flywheel, pickups and part of the wiring of a P750, 750S, Monster or Sport. Probably not worthwile unless you can grab all the parts for little money.
User avatar
Derek
paso grand pooh-bah
Posts: 769
Joined: Thu Nov 03, 2011 10:13 am
model: 907 I.E.
year: 1994
Location: Scotland

Re: First post and an ignition problem!

Post by Derek »

Spaggy wrote:Derek.

Thanks for that, but the Kokusan replacement stuff is not compatible with the DigiPlex box, so can't really be used on the 906.
That came from the manufacturer in the last few days.
I'm not suggesting that you convert to Kokusan or a Kokusan equivalent. If you look into the Ignitech website you will see that their modules can be used with practically any motorcycle that has an ignition pickup or crank sensor. I'd be very surprised if one of their modules is not compatible with the 906, replacing the Digiplex with a better product.
Check out the Sparker TCI http://www.ignitech.cz/en/vyrobky/tci/tci.htm
And also Brad Black's blog http://bradthebikeboy.blogspot.com/2018 ... t-for.html
And this pdf from ignitech about replacing the Digiplex on the early 900SS http://www.ignitech.cz/old/english/tci/ ... giplex.doc
1994 907ie
2017 Supersport 939
2015 Scrambler Classic
1982 Pantah 500SL (now sold)


Scotland
Post Reply