Clutch slave rubber boot??

discussions specific to the 907IE
Post Reply
Crumpati
Posts: 31
Joined: Mon Nov 28, 2011 8:50 am
model: 907 I.E.
year: 1993
Location: idsvold QLD Australia

Clutch slave rubber boot??

Post by Crumpati »

Hi again guys, on my voyage of discovery I unbolted the clutch slave to see if it was leaking, (Id lost clutch about 5 years ago and had to refill and bleed it up). It appears there was no leak of fluid, but it must have gone somewhere? Is this normal for it to disappear over the years.The other thing was the rubber boot which I presume protects the actuator rod from the chain gunge has a hole in it, so I will need to replace. Does the small end of the boot go on the rod and the big end to the piston or the other way round? Is it just held in place by the sprocket cover? thanks again.
User avatar
Derek
paso grand pooh-bah
Posts: 769
Joined: Thu Nov 03, 2011 10:13 am
model: 907 I.E.
year: 1994
Location: Scotland

Re: Clutch slave rubber boot??

Post by Derek »

Big end goes against the piston. It is simply sandwiched between the slave cylinder and the end of the shaft.
1994 907ie
2017 Supersport 939
2015 Scrambler Classic
1982 Pantah 500SL (now sold)


Scotland
Crumpati
Posts: 31
Joined: Mon Nov 28, 2011 8:50 am
model: 907 I.E.
year: 1993
Location: idsvold QLD Australia

Re: Clutch slave rubber boot??

Post by Crumpati »

thanks for that. After pulling the piston and tidying up the bore I have decided to replace the piston, seal and spring. Apparently I should replace the push rod O rings as well. The pushrod pulls out without too much resistance so the O rings will be a simple job, there are no oil leaks at the moment from either end. Should I replace any other seals now I have disturbed the push rod?
Post Reply